Reduce the Bounce

Topics: User Forum
Nov 17, 2006 at 5:35 PM
Is there anything else I can do to reduce bounce besides set the objects restitution to 0? I understand why there is still bounce, but was woundering if there were any settings that might reduce the bounce due to penetration.

Thanks

Gudy
Coordinator
Nov 17, 2006 at 6:20 PM
Try increasing "AllowedPenetration" on the PhysicsSimulator object. And try reducing the BiasFactor from .8 to something like .2 or .3

The Allowed penetration parameter will let your objects overlap a little before the response impulse kicks in. I think by default it is set to 1, which, if you are using normal sprites, means 1 pixel. You should be able to increase it a bit without compromising the visuals too much.

-jeff
Coordinator
Dec 10, 2006 at 10:13 PM
The bounce bug has now been squashed!
Dec 12, 2006 at 1:14 AM
I will give it a try when I get a chance, I have some other more pressing things right now (work, can you believe they actually expect me to work?)

Thanks for all your hard work on this, it is fantastic!

Gudy