This project has moved and is read-only. For the latest updates, please go here.

Xbox help

Apr 7, 2009 at 2:14 AM
Is there any simple way to get farseer to work on the damn Xbox
Its been giving me so much trouble since the beggining
There is only windows in the xna3 branch so i use the class library,
I add it in and reference it,
It tells me the gravity controller doesnt exist, or the namespace for mathematics has been used before

The when i get it to shut up about that it complains about ambiguity between xna math and farseer math,
so i tell it to use farseer math,
then when i go to draw it tells me i can use a vector2 then when i plug in geom.position it says its not a rectangle,
yeah stupid its a vector2,
then i make a new rectangle with the geom.position points x, y,
finally no errors,
i build
it tells me


what the hell!
This is my first time using xna on the Xbox but ive deployed simple stuff already,
Is there a nice quick tutorial on how to wrestle this beast?!!!
Apr 7, 2009 at 10:47 AM
First, grab a copy of the stick 2.0.1 install (sorry don't know how to do it for dev builds). Then open it up in visual studio (or visual C# express, whatever...) and right click on the project in the project explorer and select the Create Copy of project for Xbox 360. Then open the project settings and under the build tab (i think) theres a Build Compilation symbols (i think thats the name). Anyway, its a box that has the word XBOX in it, add XNA to the list and youre good to go.
Apr 7, 2009 at 7:20 PM
Thanks man i downloaded that version and made the xbox copy,
but i had not tried(nor thought of) changing the build type,
especially from xbox to xna.
But i am not home right now so I must try that when i get home,
you may have just saved me(and these forums) from an overdramatic rant.
Apr 7, 2009 at 10:56 PM
took me a while to find it,
it was under build
but i didnt recognize the compilation things,
it had a box with XBOX;XBOX360 next to it so i just added ;XNA and it worked perfect
Thanks a ton man this is such a relief
Apr 8, 2009 at 1:36 AM
You're welcome! i initially went around removing all of the #if XNA blocks but then i realized (through someones post on this forum) that you can just add XNA (its one of the few bugs with the Xbox part of XNA Game Studio) and it works.
Apr 8, 2009 at 5:19 AM
Haha i was doing the same thing,
except it caused aot of unneccesary deletes and a big mess,
You saved me a  ton of frustration and panic attacks,
I was porting some of my game over to xbox so i could start working on the DBP project,
So i was about to go completely ape shit if i could use farseer,
I love farseer and i cant give it up(luckily i dont have to now)
Apr 8, 2009 at 7:07 AM
Yeah Farseer is great. After finishing my game, i'm planning on writing a framework with all sorts of neat features, not the least of which is a unified API for physics (so i can use different engines without too much impact to code that relies on a physics engine).
Apr 19, 2009 at 8:19 AM
i also went around and manually removed all of the checks
thats how the version i am using now is (might make it a bit hard for me to upgrade to 2.1 when its out)

but a few weeks ago i found out that i could just put xna there and it would fix it all

is this a problem with visual studio not setting up the project right??
Apr 19, 2009 at 9:29 AM
Pretty much. Since you con only develop on the xbox with XNA, you have to check for xbox and xna if you only want something with xna. Either that, or fix all of your projects by adding the xna precompiler symbol.
Apr 19, 2009 at 4:16 PM
Yeah it's XNA Game Studio's fault alright. If you look at the normal Windows project it has "WINDOWS;XNA" in the Conditional compilation symbols, but after you create a copy for XBox, it's nuked the XNA symbol. I guess even MS makes bugs ;)

Perhaps the Farseer for XNA should come with an XBOX project already in the solution, or in a separate solution? I've seen other libraries do this.
Apr 19, 2009 at 4:52 PM
I've just added a Xbox360 branch to the source control. This will make sure that the XNA compiler flag is enabled.
I will also write about it in the manual.