Im confused!

Jul 17, 2009 at 11:53 AM

Okay, ive downloaded Farseer Physics 2.1.1 XNA with advanced samples

I got:

VS 2005
VS 2008 Professionel
VS 2005 Express
VS 2008 Express
XNA Game Studio Express
XNA Game Studio 2.0 

Installed, and NONE of them will open the damn project, wtf!? 

 

Jul 17, 2009 at 1:18 PM

All you need is XNA Game Studio 3.1 and VS 2008 Express then it will open.

Nothing else is needed.

Coordinator
Jul 17, 2009 at 2:29 PM

That's right. Our only prerequisites are XNA Game Studio 3.0 (3.1 will be the required in the next version: Farseer Physics 2.2) and Visual Studio 2008 Express (or professional/team suite)

We are always trying to stay close to the latest version of the XNA libraries and the .NET framework. This way we can make our lives easier and improve the quality of the library. If you insist on using an old version of the .net library or XNA game studio, it is just a small matter of copying the files over in a old project file and change a few lines. We are pretty (version) backwards compatible at the moment but in Farseer Physics 3.0 we will target the latest .net framework.

Jul 17, 2009 at 2:32 PM

Just thought i should say also genbox that 3.1 is backwards compatable with 3.0 isnt it?

I think i only have 3.1 installed on my laptop.
But i can make 3.1 and 3.0 projects

(i could be wrong thou)

Coordinator
Jul 17, 2009 at 3:24 PM

Yes it is.

XNA Game Studio 3.1 contains both the 3.0 and 3.1 redistributable.

Jul 17, 2009 at 9:16 PM

Well, i didn't know 3.0 or 3.1 was out, its very difficult to get the lastest i think, a quick search on XNA Game Studio gave me 2.0 from MS, which i, of cause thought was the newest as it told nothing about the 3.0 or 3.1

Coordinator
Jul 17, 2009 at 11:18 PM

You have 2 users?

Anyway, I agree with you. New XNA Game Studio releases are not really a big media thing. I follow a lot of development blogs and most of them does not even care. It would help you a lot if you follow Ziggyware.com. He has excellent news from the game development world and is sometimes the first place I catch wind of bleeding edge news.

Jul 19, 2009 at 4:25 PM

I agree, it would be nice to have some more announcment.

Maybe it would be easier if you could, in some way, make it clear under the download section which XNA Game Studio (or VS) version to use.

Coordinator
Jul 19, 2009 at 5:28 PM

I will do that in future releases. Thanks